- +

Автор: clawfulaci Тема: Графические глюки во всплывающих подсказках  (Прочитано 388 раз)

Оффлайн clawfulaci

  • Начинающий
  • *
  • Сообщений: 2
  • Репутация: +0/-0
    • Просмотр профиля
Привет

Проявление этого бага/фичи/побочного эффекта заметил 3-4 месяца назад в Xubuntu 16.04, хотя возможно проблема гораздо старше или вообще свойственна только конкретно моей конфигурации и о ней никто не знает. Что это из себя представляет: чаще всего находясь в Chromium при наведении курсора на какую-нибудь кнопку, ссылку, превью, вкладку и т.п. вместо обычной всплывающей подсказки с серым полупрозрачным фоном и текстом белого цвета, появляется её сломанная версия с чёрной полоской во всю подсказку. Бывает также, что подобным образом себя ведут подсказки, всплывающие над иконками дока Plank, только по мимо чёрных полос в поле подсказки/описания могут попадать обрывки вкладок из Chromium или куски фона рабочего стола. Ситуация с Plank'ом сегодня упорно не воспроизводилась, поэтому скринов с ним нет. Частота появлений глюка нелинейна. Иногда вовсе не появляется (как сегодня с док-баром), а иногда через каждые ~ 10 наведений курсора. Но он никогда не воспроизводится на элементах интерфейса системного лотка (индикатор раскладки клавы, календарик и т.п.).

Система установленна на ноутбук, но постоянно работает с внешним монитором через VGA разъём (встроенный экран ноутбука при этом отключён через Настройки > Дисплей). Композитор идущий по-умолчанию выключен и заменён на Compton для борьбы с разрывами. Chromium запускается с параметрами --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers для полной активации аппаратного ускорения. Возможно, есть какие-то способы решения?

Собственно глюки - https://imgur.com/a/YJhhd

$ neofetch
OS: Ubuntu 16.04.2 LTS x86_64
Model: ***
Kernel: 4.4.0-77-generic
Uptime: 5 days, 1 hour, 58 mins
Packages: 2303
Shell: bash 4.3.46
Resolution: 1680x1050
DE: Xfce
WM: Xfwm4
WM Theme: Arc-Dark
Theme: Arc-Dark [GTK2], Breeze [GTK3]
Icons: Papirus-Dark [GTK2], Breeze [GTK3]
Terminal: xfce4-terminal
Terminal Font: DejaVu Sans Mono 10
CPU: Intel Pentium 2020M (2) @ 2.400GHz
GPU: Intel Ivybridge Mobile
Memory: 3494MiB / 7823MiB
$ xfconf-query -c xfwm4 -p /general/use_compositing
false
« Последнее редактирование: Май 07, 2017, 07:12:08 от clawfulaci »

Оффлайн denkin

  • Global Moderator
  • Старожил
  • *****
  • Сообщений: 1115
  • Репутация: +67/-2
    • Просмотр профиля
Прошу вставить изображения согласно правил
Руководство по добавлению изображений на форум

Оффлайн clawfulaci

  • Начинающий
  • *
  • Сообщений: 2
  • Репутация: +0/-0
    • Просмотр профиля
Я кажется случайно нашёл откуда ноги растут и определённо это баг, которому уже скоро 3 годика - https://bugs.chromium.org/p/chromium/issues/detail?id=442111&q=LIBGL_DRI3_DISABLE&colspec=ID%20Pri%20M%20Iteration%20ReleaseBlock%20Cr%20Status%20Owner%20Summary%20OS%20Modified

Оффлайн denkin

  • Global Moderator
  • Старожил
  • *****
  • Сообщений: 1115
  • Репутация: +67/-2
    • Просмотр профиля
у меня подобный глюк был на разных компах и картах, вплоть до опера+интел на сегодня, compton тут ничего не решит и вряд ли виновата видеокарта.
и картинки так и не вставлены по правилам - это что, принципиальная позиция - не выполнять правила?