Русскоязычное сообщество Xubuntu

Установка и настройка => Установка и восстановление => Тема начата: Kamrad от Июнь 15, 2014, 10:39:05

Название: Помогите переписать скрипт установки принтера
Отправлено: Kamrad от Июнь 15, 2014, 10:39:05
Доброго времени суток, друзья!
Некоторое время назад попался мне очень удачный скрипт (см. вложения), который беспроблемно прицеплял принтеры Canon на любые "бунты". Но вот оказия - данный скрипт был "завязан" на ресурс UbuntuOne, который теперь закрыт. Вопрос к программистам - как грамотно модифицировать скрипт, чтобы он обращался не к сетевому ресурсу, а к локальным файлам в домашнем каталоге?
Название: Re: Помогите переписать скрипт установки принтера
Отправлено: werwolf от Июнь 15, 2014, 11:07:12
canon_lbp_setup.sh его уже давно перенесли на гугл диск
Spoiler: показать
https://googledrive.com/host/0Byemcyi98JRjUjJKMnlqSVVnVlk/canon_lbp_setup.sh


http://help.ubuntu.ru//wiki/canon_capt?redirect=1
Название: Re: Помогите переписать скрипт установки принтера
Отправлено: Kamrad от Июнь 15, 2014, 15:52:45
canon_lbp_setup.sh его уже давно перенесли на гугл диск
Spoiler: показать
https://googledrive.com/host/0Byemcyi98JRjUjJKMnlqSVVnVlk/canon_lbp_setup.sh


http://help.ubuntu.ru//wiki/canon_capt?redirect=1

О, отличная новость!
Название: Re: Помогите переписать скрипт установки принтера
Отправлено: Kamrad от Ноябрь 05, 2017, 15:31:00
Чтобы не плодить тем-клонов - указанный скрипт не устанавливает принтеры серии Canon LBP на дистрибтивах, начиная с 16.04 и новее -

"dpkg-deb: ошибка: «cndrvcups-common_3.21-1_amd64.deb» не является архивом в формате debian
dpkg: ошибка при обработке архива cndrvcups-common_3.21-1_amd64.deb (--install):
подпроцесс dpkg-deb --control возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
cndrvcups-common_3.21-1_amd64.deb
Ошибка при установке пакета cndrvcups-common_3.21-1_amd64.deb"