Форум русскоязычного сообщества Xubuntu

Установка и настройка => Оборудование => Тема начата: Multik001 от августа 02, 2019, 22:58:28

Название: Не работает WIFI нет драйверов BCM43228
Отправлено: Multik001 от августа 02, 2019, 22:58:28
Всем привет, столкнулся с проблемой wifi и я( на ноутбуке HP нет драйверов для моей WIFI карточки BCM43228, по проводу подключить ноутбук не всегда получается, поэтому решил научиться устанавливать драйвера фоффлайн, в ИНСТРУКЦИИ (https://help.ubuntu.ru/wiki/broadcom) есть описание как делать оффлайн установку
Установка Offline

В том случае, когда проводная сеть недоступна, есть возможность установить bcmwl-kernel-source с установочного диска.
Для этого нужно вставить установочный CD/DVD или USB и скопировать эти файлы в домашнюю директорию.
На установочном диске (флешке) эти файлы находятся в директориях:

/pool/main/d/dkms/dkms_XXXXX.deb
/pool/restricted/b/bcmwl/bcmwl-kernel-source_XXXXX.deb

После чего, запускаем саму установку:

sudo dpkg -i *.deb

На Xubuntu 18.04 требуются еще подтянуть пакеты, но без инета это сделать не получается...
Может есть еще какой способ установить драйвера?
 
Название: Re: Не работает WIFI нет драйверов BCM43228
Отправлено: denkin от августа 03, 2019, 11:34:02
1. Получить список пакетов и скачать на компьютере с доступом в интернет.
2. Подключится по кабелю, где это возможно и закончить установку.
По другому никак.
Название: Re: Не работает WIFI нет драйверов BCM43228
Отправлено: Multik001 от августа 03, 2019, 23:32:36
Цитата: denkin от августа 03, 2019, 11:34:021. Получить список пакетов и скачать на компьютере с доступом в интернет.
Как получить весь список пакетов и как их скачать?
Название: Re: Не работает WIFI нет драйверов BCM43228
Отправлено: denkin от августа 03, 2019, 23:57:25
При попытке установки разве не говорит?
Название: Re: Не работает WIFI нет драйверов BCM43228
Отправлено: butjapka от августа 04, 2019, 22:05:35
А этот способ (http://ubuntovod.ru/instructions/broadcom-bcm4318.html) заведет?
Название: Re: Не работает WIFI нет драйверов BCM43228
Отправлено: Multik001 от августа 08, 2019, 21:43:41
Без интернета как без воды... ни тудынисюды... Сижу щас на Xubuntu 16.04 с инетом стоит еще Xubuntu 18.04 без драйверов и интернета( как установить драйвера так и не разобрался( впору хоть WIFI планку в ноуте менять, не возиться же каждый раз так с драйверами...
Название: Re: Не работает WIFI нет драйверов BCM43228
Отправлено: denkin от августа 08, 2019, 23:24:02
Цитата: Multik001 от августа 08, 2019, 21:43:41впору хоть WIFI планку в ноуте менять,
Не самый плохой вариант в случае с Broadcom, там как дрова не допиливай, всё равно проблемы будут на каждом шагу: ядро обновилось = драйвер переустанавливай, или плохой приём будет, или греться будет.
У моей супруги нетбук с Broadcom был :( .
Название: Re: Не работает WIFI нет драйверов BCM43228
Отправлено: Slav164 от августа 09, 2019, 02:53:39
Цитата: Multik001 от августа 08, 2019, 21:43:41Сижу щас на Xubuntu 16.04 с инетом стоит еще Xubuntu 18.04 без драйверов и интернета
Так а что мешает скачать из 16 и положить в 18 и установить?
Название: Re: Не работает WIFI нет драйверов BCM43228
Отправлено: Multik001 от августа 15, 2019, 00:44:40
Все решил подключением телефона по проводу как USB модем, тк оффлайн установка требовала слишком много зависимостей
(Чтение базы данных ... на данный момент установлено 179223 файла и каталога.)
Подготовка к распаковке bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu4_amd64.deb ...
Распаковывается bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu4) на замену (6.30.223.271+bdcom-0ubuntu4) ...
Подготовка к распаковке dkms_2.3-3ubuntu9.2_all.deb ...
Распаковывается dkms (2.3-3ubuntu9.2) на замену (2.3-3ubuntu9.2) ...
dpkg: зависимости пакетов не позволяют настроить пакет bcmwl-kernel-source:
 bcmwl-kernel-source зависит от linux-libc-dev, однако:
  Пакет linux-libc-dev не установлен.
 bcmwl-kernel-source зависит от libc6-dev, однако:
  Пакет libc6-dev не установлен.

dpkg: ошибка при обработке пакета bcmwl-kernel-source (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет dkms:
 dkms зависит от gcc, однако:
  Пакет gcc не установлен.
 dkms зависит от dpkg-dev, однако:
  Пакет dpkg-dev не установлен.
 dkms зависит от make | build-essential, однако:
  Пакет make не установлен.
  Пакет build-essential не установлен.

dpkg: ошибка при обработке пакета dkms (--install):
 проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для man-db (2.8.3-2ubuntu0.1) ...
При обработке следующих пакетов произошли ошибки:
 bcmwl-kernel-source
 dkms