Форум русскоязычного сообщества Xubuntu

Установка и настройка => Оборудование => Тема начата: Kamrad от марта 18, 2013, 22:27:29

Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: Kamrad от марта 18, 2013, 22:27:29
Суть проблемы в том что после настройки переключения раскладки клавиатуры (см. ниже)
(http://i54.fastpic.ru/big/2013/0318/d6/b817a5089d60d8849f7c18f8f8a932d6.png)

через некоторое время (даже без перезагрузки системы) всё слетает вот так:

(http://i51.fastpic.ru/big/2013/0318/7b/df3f2bfa5837458beacc1981c85b967b.png)

Может быть, кто-то уже с этим сталкивался?
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: butjapka от марта 19, 2013, 07:33:07
Желательно в вопросе указывать хотя бы название дистрибутива.
Попробуйте подправить в /etc/default/keyboard

    XKBMODEL="pc105"
    XKBLAYOUT="us,ru"
    XKBVARIANT=","
    XKBOPTIONS="grp:ctrl_shift_toggle,grp_led:scroll"

только вместо ctrl_shift_toggle подставляйте свое сочетание клавиш

Затем в терминале


sudo udevadm trigger --subsystem-match=input --action=change
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: Kamrad от марта 19, 2013, 18:44:51
Так и делал, но всё равно проблема осталась.
P.S. Дистрибутив - Xubuntu 12.10.
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: xf∞ от марта 19, 2013, 19:40:12
попробуйте настроить, и сразу же перезагрузиться. перед перезагрузкой сохранить сеанс.
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: LingVist от июля 21, 2013, 12:34:43
Есть вопрос по поводу клавиатуры. Новую тему заводить не хочется, напишу сюда.
Когда включена русская раскладка, не работают горячие клавиши в LibreOffice - CTRL+C, CTRL+V, CTRL+S и другие. Это как-то можно исправить?
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: myth от июля 21, 2013, 17:04:13
Цитата: LingVist от июля 21, 2013, 12:34:43
Когда включена русская раскладка, не работают горячие клавиши в LibreOffice - CTRL+C, CTRL+V, CTRL+S и другие. Это как-то можно исправить?


Никогда не сталкивался с подобными проблемами, отлично все копируется в русской и английской расскладках по ctrl+c, ctrl+x, shift+ins вставляется по ctrl+v, ctrl+ins без проблем, также работают другие сочетания клавиш в любом из gtk приложений. При всем при этом у меня установлена версия ubuntu 12.04.2 lts, рабочее окружение обновлено до xfce 4.10.1, если ключ версии xfce4 не врет:
$ xfce4-session -V
xfce4-session 4.10.1 (Xfce 4.10)

Недавно поставил себе LibreOffice, сейчас проверил в нем - все сочетания клавиш одинаково успешно работают при русской и английской расскладках. Я понимаю, что LibreOffice'оф достаточно много различных версий, я использую 4-ю, если быть точнее:
$ libreoffice --version
LibreOffice 4.0.4.2

Клавиатура у меня genius KB-06X2, обычная стандартная клава на 105 клавиш, без дополнительных; расскладки переключаю по Alt+Shift и клавишей Compose не пользуюсь. В настройках xkb-plugin я ничего не менял и они остались точно такиеже как и при установке системы:
(http://storage2.static.itmages.ru/i/13/0721/s_1374411057_4217918_2636046d3f.png) (http://itmages.ru/image/view/1130614/2636046d)
Вот закладка настроек расскладок клавиатуры, здесь тоже ничего не трогал:
(http://storage3.static.itmages.ru/i/13/0721/s_1374411061_3303381_67f4607955.png) (http://itmages.ru/image/view/1130615/67f46079)
Не знаю что такое "стандартные системные параметры", но на всякий случай приведу содержание файла /etc/default/keyboard:
[spoiler]$ cat /etc/default/keyboard
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=",winkeys"
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll,numpad:microsoft"

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz[/spoiler]

Не уверен, что это хоть как-то кому-нибудь пригодится, однако, у меня все работает именно в такой конфигурации, как и работало с момента установки.
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: LingVist от июля 21, 2013, 18:07:06
Я понимаю, что странно это. Тем более что на десктопе с LibreOffice 4.0.4.2 все работает на ура. Не работает на ноутбуке Asus X54C c LibreOffice 4.1.0.3. И причем только в этом редаторе, везде все нормально.
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: myth от июля 21, 2013, 18:41:14
Ну да, немногие являются счастливыми обладателями этой модели Asus с такойже системой. Я к тому, что врядли ктото станет покупать Asus X54C и устанавливать туда xubuntu и офис только за тем, чтобы посмотреть какие в нем настройки клавиатуры и разобраться с горячими клавишами.

Может поделитесь своими настройками, к примеру, как это сделал я?

минимум, что интересует:
1. вывод
cat /etc/default/keyboard
2.скрин 3й вкладки
xfce4-keyboard-settings
3.скрин xkb-plugin
правый щелчек в трее на значке флага/или надписи(ru/en) -> свойства
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: xf∞ от июля 21, 2013, 18:56:24
попробуйте это сделать на английском языке и проверьте, работает ли control+insert. shift+insert.
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: myth от июля 21, 2013, 19:02:43
+ вообще работают ли какиелибо сочетания при русской расскладке, например ctrl+a (выделить все) еще какие-нибудь...
точно ли это только глюк libreoffice, где еще пробовали?

и всю эту громадную инфу желательно указывать сразу в вопросе.
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: LingVist от июля 21, 2013, 19:26:32
Все решилось до банальности просто. У меня в настройках русская раскладка стояла первой. как только поставил ее на второе место, все сразу заработало.
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: myth от июля 21, 2013, 19:41:01
Рад, что сами справились :) полезно всеже иногда заглядывать в настройки)
Название: Слетает настройка переключения раскладки клавиатуры
Отправлено: LingVist от июля 21, 2013, 21:27:46
Так я это видел, но как-то даже подумать не мог, что расположение может оказывать какое-то влияние. Тем более, что когда ставил систему, изначально выбрал английский, и уж потом добавил русский. Век живи - век учись :)
Название: Re: Слетает настройка переключения раскладки клавиатуры
Отправлено: Kamrad от августа 17, 2014, 23:11:17
Вот правильный синтаксис настройки раскладки клавиатуры (переключение раскладок левым CTRL):

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:ctrl_left_toggle,grp_led:scroll"