Просмотр сообщений

В этом разделе можно просмотреть все сообщения, сделанные этим пользователем.

Сообщения - AlphaGeo

1
В общем, обновился до 14.04 и теперь сеть вылетает день / через день... :(
Соединение настроено через Network Manager. Знаю -- зло, но я честно пытался настроить через конфиги и, к сожалению, у меня ничего не запустилось.
Соответственно, вариант
Цитата: butjapka от июня 30, 2014, 21:16:01
sudo ifdown eth1
sudo ifup eth1


не прокатывает.
Пробовал так:
sudo service network-manager restart
но не помогает. После перезапуска службы попытки восстановления соединения безрезультатны. В терминале выводится следующее:
$ nmcli con up id "Провод"
(process:4326): GLib-CRITICAL **: Source ID 80 was not found when attempting to remove it
Ошибка: сбой активации соединения: Message did not receive a reply (timeout by message bus)

Подозреваю, что и ранее (до 13.10) я не пользовался этой командой, потому что после ее исполнения ситуация не исправлялась.
Вообще, подключение к провайдеру происходит через VPN, и Network Manager вроде проводное (ethetnet) соединение активирует нормально, но вот на VPN вылетает. В списке сервисов есть некий xl2tpd (я так понимаю, отвечающий за VPN-соединение) -- пробовал перезапускать его, но эффекта никакого.
И вместе с тем, после перезагрузки всей системы все коннектится без проблем. Может, есть еще какие-то сервисы или процессы, отвечающие за сетевые соединения?
2
Я же написал, что при запуске с sudo система попросту виснет и приходится её перезапускать полностью, притом через отключение питания...
3
Иногда «отваливается» интернет, и в восстановлении соединения помогает перезапуск сетевой службы (чтобы не перезапускать всю систему целиком).  В Xubuntu 13.04 выполнял команду sudo /etc/init.d/network restart После обновления до 13.10 в терминале в ответ на эту команду высвечивается предложение использовать команду servise. Пробовал запускать без sudo команду service networking restart В ответ -- «неизвестная команда». При запуск той же команды, но с sudo в терминале выводится сообщение, что служба остановлена, а затем запущена, однако при этом сначала пропадает рабочий стол, а затем и панель, и далее система вообще перестает как-либо реагировать на мой действия.
Собственно, вопрос. Как в Xubuntu 13.10 (надеюсь, что и в 14.04 так же) перезапустить сетевую службу?