Xbuntu 12.10 - не проходят обновления и не устанавливается ПО

Автор limbiczen, января 18, 2015, 07:16:52

« предыдущая - следующая »

limbiczen

Доброго всем времени суток, надеюсь я выбрала правильный раздел для темы.

История такова: в тяжелый момент жизни ноутбука Asus K40IN (Intel, 512MB), жесткий диск отказал, и в результате продолжительных инсинуаций и девиаций с системой и биосом, с телефона на базе андроид был установлен Xubuntu 12.10 как единственное решение проблемы.

Конечная цель: установить виндоуз дуально вместе с Хубунтой или же хотя бы на виртуальном приводе.
Задачи: установить Wine и, в лучшем случае, Gparted для обозначения ntfs раздела под винду.
Трудности:
-Система не желает производить апдейт. Последние строки в терминале:

W: Не удалось получить http://ru.archive.ubuntu.com/ubuntu/dists/quantal-backports/restricted/binary-i386/Packages  404  Not Found
W: Не удалось получить http://ru.archive.ubuntu.com/ubuntu/dists/quantal-backports/universe/binary-i386/Packages  404  Not Found
W: Не удалось получить http://ru.archive.ubuntu.com/ubuntu/dists/quantal-backports/multiverse/binary-i386/Packages  404  Not Found
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

Соотвественно, при попытке установить wine или gparted терминал пишет следующее:

Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:
Пакеты, имеющие неудовлетворённые зависимости:
wine : Зависит: wine1.6 но он не будет установлен или
                        wine1.7 но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.


Делала apt-get update, apt-get upgrade, apt-get -f install, dpkg --configure -a, проблема осталась. В dpkg --get-selections все пакеты в статусе install, пишет следующее:


Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.


Очень надеюсь на совет и помощь по конкретному случаю.
Спасибо

werwolf

поддержка 12.10 закончилась 16 мая 2014.
если нужно использовать старую версию
http://help.ubuntu.ru/wiki/old_ubuntu_versions
Старые версии Ubuntu не поддерживаются Canonical, это означает, что все официальные репозитории для них заморожены и не пополняются обновлениями, устраняющими проблемы с безопасностью. Категорически не рекомендуется использовать неподдерживаемые версии Ubuntu. Ubuntu поддерживает автоматический переход на новую версию без необходимости переустановки системы, поэтому рекомендуется заранее воспользоваться этой возможностью и обновить свой дистрибутив.
После окончания поддержки дистрибутива он удаляется с серверов, на которых хранятся репозитории Ubuntu. Это приводит к тому, что при попытке обновить список доступных пакетов выдаётся предупреждение о недоступности всех основных репозиториев. Однако все пакеты из репозитория на момент окончания поддержки не удаляются в никуда, а переводятся на другой сервер, поэтому если вам зачем-либо понадобится репозиторий для неподдерживаемой версии Ubuntu, вы сможете его получить. Для этого заменить все ссылки в файле /etc/apt/sources.list, отвечающие за официальные репозитории, на:
http://old-releases.ubuntu.com/ubuntu

лучше использовать актуальные lts релизы 12.04.5 или 14.04.1

butjapka

января 18, 2015, 21:03:36 #2 Последнее редактирование: января 18, 2015, 21:29:47 от butjapka
Цитата: limbiczen от января 18, 2015, 07:16:52

Конечная цель: установить виндоуз дуально вместе с Хубунтой или же хотя бы на виртуальном приводе.
Задачи: установить Wine и, в лучшем случае, Gparted для обозначения ntfs раздела под винду.


можете загрузиться в лайв режиме, настроить соединение интернет, установить на загруженную ОС gparted (при этом конечно не перезагружатья) и отхряпать раздел под виндоуз (ближе к завершению статьи увидите). Ну как советовали выше с переходом на более актуальную lts версию дистрибутива.
Да и советую ресурс, по ссылкам выше, к просмотру

runtik

Цитироватьс телефона на базе андроид был установлен Xubuntu 12.10
Это каким образом, опишите, пожалуйста. Очень интерсно.

limbiczen

werwolf, [butjapka], спасибо за ответ. А 14.10 чем плоха? Удалось скачать ее (качаю через специальную андроид программу, а не через форум, других вариантов на данный момент нет, скорость плохая, нахожусь в диких местах). Попробую через нее gparted поставить. Но я так понимаю, версия новая и относительно нестабильная.

Цитата: runtik от января 19, 2015, 06:42:17
Это каким образом, опишите, пожалуйста. Очень интерсно.

На андроид ставится программа Drive Droid (есть в гугл плей), нужны права рут. Телефон в режим зарядки онли, в биосе приоритет на съемное устройство (отображается как usb), в программе монтируется образ. С виндоуз не прокатило, а вот любой дистрибутив линукса можно скачать прямо из программы и тут же смонтировать.

werwolf

Цитата: limbiczen от января 19, 2015, 07:27:08
werwolf спасибо за ответ. А 14.10 чем плоха? Удалось скачать ее (качаю через специальную андроид программу, а не через форум, других вариантов на данный момент нет, скорость плохая, нахожусь в диких местах). Попробую через нее gparted поставить. Но я так понимаю, версия новая и относительно нестабильная.

https://ru.wikipedia.org/wiki/Ubuntu
поддержка 14.10 до июль 2015
поддержка 14.04 апрель 2019
лучше использовать версию с долговременной поддержкой и стабильную.

butjapka

января 19, 2015, 21:26:19 #6 Последнее редактирование: января 19, 2015, 21:35:23 от butjapka
limbiczen, есть еще способ, когда устанавливаете систему, на этапе подготовки разделов на жестком диске выделить раздел ntfs и настроить автоматическое монтирование тома.
Кстати тут есть торрент ссылка на образ (выберите в списке xubuntu-14.04.1-desktop-i386.iso.torrent или 64 битную - xubuntu-14.04.1-desktop-amd64.iso.torrent), и загрузите образ, например, с помощью bittorrent на андроид