Не обновляется ядро в 16.04

Автор Multik001, июля 31, 2019, 21:08:59

« предыдущая - следующая »

Multik001

Подскажите в чем может быть причина, сделал обновления, ядро было 4.13.0-37, вроде как качалось 4.15.0-45, все установилось перезагрузился проверяю стоит опять 4.13.0-37, а 4.15.0-45 предлагает удалить....

sergei@ivanpc:~$ sudo apt full-upgrade
[sudo] пароль для sergei:
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Расчёт обновлений... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-4.15.0-45 linux-headers-4.15.0-45-generic
  linux-image-4.15.0-45-generic linux-modules-4.15.0-45-generic
  linux-modules-extra-4.15.0-45-generic
Для их удаления используйте «sudo apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
sergei@ivanpc:~$ uname -a
Linux ivanpc 4.13.0-37-generic #42~16.04.1-Ubuntu SMP Wed Mar 7 16:03:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
sergei@ivanpc:~$


denkin

Может быть обнаружен какой то баг и обновление отменили, пакеты из репозитория изьяли. Бывает!

XapoH

августа 02, 2019, 10:51:12 #2 Последнее редактирование: августа 02, 2019, 10:57:18 от XapoH
Судя по вики - это ядро (и последующие) на 16й версии "больше не жилец"
Да и вообще - а оно надо?
"...Версия 4.13.
Основные улучшения:
        Добавлена подсистема для работы с UUID/GUID
        Добавлена ядерная реализация протокола TLS
        Поддержка огромного количества нового оборудования, в том числе начальная поддержка графики Intel Cannonlake/Coffeelake, однако драйвера термодатчика Zen/Ryzen до сих пор нет
        Многочисленные улучшения дисковой подсистемы и файловых систем ext4, Btrfs, F2FS, UBIFS, XFS
        В ext4 появилась опция, увеличивающая максимальное количество файлов в директории с 10 млн до 2 млрд
        Теперь по-умолчанию используется версия протокола SMB 3.0, представленная с Windows 8

Версия 4.14.
    Основные улучшения:
        Улучшения для Vega в AMDGPU, поддержка modesetting GP108 / GT 1030 в Nouveau, добавление кода для работы с чипами Cannonlake «Gen 10» в видеодрайвер Intel
        Поддержка HDMI CEC для Raspberry Pi и Allwinner Sunxi
        Многочисленные улучшения архитектуры Aarch64 для Raspberry Pi Zero W, Banana Pi и множества других плат, обновления архитектуры MIPS и прекращение поддержки процессоров серии R6000
        Увеличение лимитов размера оперативной памяти для новых процессоров Intel: адресное пространство до 128Пб, физическая оперативная память до 4Пб
        Поддержка сжатия Zstd для Btrfs и SquashFS
        Поддержка распараллеливания в Cgroup2

Версия 4.15.-- используется в Ubuntu 18.04.
    Основные улучшения:
        Новая архитектура -- RISC-V, драйверы для RISC-V устройств ожидаются в следующем релизе
        Информация об уязвимостях используемого процессора теперь доступна в /sys/devices/system/cpu/vulnerabilities, определить подверженность Meltdown или Spectre стало проще
        Наконец-то обеспечена поддержка температурного датчика AMD Zen (Ryzen/Threadripper/EPYC), также добавлена поддержка температурного мониторинга Intel Coffee Lake и Cannonlake, а также GeForce GTX 1000
        Добавлен драйвер Radeon RX Vega
        Обеспечена поддержка новых SoC и одноплатных компьютеров: Allwinner R40, Broadcom Hurricane 2, CubieBoard 6, Banana Pi M2 Ultra, Fairphone 2
        Продолжена работа по исправлению «Unix Millennium Bug» -- проблемы 2038 года" (с) Wiki

ЗЫ. Скорее всего ядро уже имеет какие-то несовместимости с железом (судя по версии линя - железо-то не самое свежее)
А что бы не досождало, можно заморозить имеющееся и забыть об обновлениях - реальных-то улучшений безопасности и поддержки (имеющегося) железа  в новых версиях нет и не будет. А вот "пропасть" что-то из поддерживаемого может.

Для заморозки ввести:
 sudo apt-mark hold linux-image-4.13.0-37-generic
 sudo apt-mark hold linux-headers-4.13.0-37-generic
потом можно  sudo apt autoremove и  sudo apt autoclean
Если надо  sudo apt update и/или sudo apt upgrade
и забыть (и забить).
(4.13.0-37 - номер текушей версии. Видно через sudo uname -a )

Multik001

Ну как то не порядок(( вывод lsb_release -a
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial
На WIKI

 


uname -a
Linux ivanpc 4.13.0-37-generic #42~16.04.1-Ubuntu SMP Wed Mar 7 16:03:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux