- +

Текущий рейтинг:
  • Менеджер питания XFCE игнорирует настройки 5 1

Автор: Ancik Тема: Менеджер питания XFCE игнорирует настройки  (Прочитано 7648 раз)

Оффлайн Ancik

  • Начинающий
  • *
  • Сообщений: 9
  • Репутация: +0/-0
    • Просмотр профиля
Доброго времени суток!
Проблема следующая - как бы я ни настраивал менеджер питания XFCE, но все равно при закрытии крышки мой ноутбук уходит в спящий режим. Он как будто совсем игнорирует настройки, то же самое и с бездействием, через некоторое время компьютер засыпает сколько времени ни выставляй и хоть совсем отключай спящий режим при бездействии.
OC Xubuntu 14.04, аналогичная ситуация и на ноутбуке и на компьютерах.
Помогите, в чем проблема?

Отмечено, как лучший ответ пользователем Ancik Август 17, 2014, 19:02:35

Оффлайн Kamrad

  • Завсегдатай
  • ***
  • Сообщений: 134
  • Репутация: +5/-0
  • Пингвиновод
    • Просмотр профиля
Re: Менеджер питания XFCE игнорирует настройки
« Ответ #1 : Август 17, 2014, 17:30:30 »
Попробуйте отключить блокировщик экрана (по умолчанию он включен).
Кто хочет на компьютере юзить, музить и вузить - пусть купит себе вульвузеллу!

"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!"

Оффлайн Ancik

  • Начинающий
  • *
  • Сообщений: 9
  • Репутация: +0/-0
    • Просмотр профиля
Re: Менеджер питания XFCE игнорирует настройки
« Ответ #2 : Август 17, 2014, 19:02:29 »
Премного благодарен.
Действительно дело оказалось не в менеджере питания, если кто-то еще столкнется с такой проблемой - то во "Все настройки"  нужно найти Light Locker и отключить его, именно он и блокирует экран.

Оффлайн РыжийПёс

  • Начинающий
  • *
  • Сообщений: 10
  • Репутация: +1/-0
    • Просмотр профиля
Re: Менеджер питания XFCE игнорирует настройки
« Ответ #3 : Октябрь 02, 2014, 19:37:40 »
Помню, сталкивался с аналогичной проблемой на 14.04, решил проблему отредактировав файл /etc/systemd/logind.conf
Там можно отредактировать и раскомментировать строку с параметром HandleLidSwitch=......

Оффлайн Pinzet

  • Начинающий
  • *
  • Сообщений: 10
  • Репутация: +0/-0
    • Просмотр профиля
Re: Менеджер питания XFCE игнорирует настройки
« Ответ #4 : Ноябрь 07, 2014, 20:24:34 »
У меня следующая проблема: при закрытии крышки ноутбука и последующим открытием тупо черный экран, не реагирующий на кнопки и тачпад. Помогает только ctrl+alt+F1 и команда startx, после чего в трее появляется два значка батареи. Или жесткая перезагрузка кнопкой питания. Кто подскажет куда копать? Система Xubuntu 14.04, ноутбук Samsung N 150 со встроенной графикой Intel.

Оффлайн roolalex

  • Начинающий
  • *
  • Сообщений: 1
  • Репутация: +0/-0
    • Просмотр профиля
Re: Менеджер питания XFCE игнорирует настройки
« Ответ #5 : Декабрь 08, 2014, 19:44:51 »
такая же проблема на eeepc. при этом еще и wifi отрубается напрочь, а перезагрузиться и выключить ноут не получается - система каждый раз предлагает сменить пользователя, остается по жесткому выдрать аккумулятор или 5 сек держать кнопку пуска. По верхнему совету вроде перестало глючить.
Две иконки потому, что апплет индикаторов уже почему-то содержит иконку батарее его можно скрыть через меню настройки аплета, а вторая в настройках питания включается соответствующей галкой.

Оффлайн butjapka

  • Global Moderator
  • Старожил
  • *****
  • Сообщений: 1231
  • Репутация: +119/-0
  • Xubuntu 16.04 LTS
    • Просмотр профиля
Re: Менеджер питания XFCE игнорирует настройки
« Ответ #6 : Декабрь 08, 2014, 22:13:25 »
я сделал следующее:
В первую очередь, нужно проверить правильно ли работает этот режим на Вашей машине.
Заходим в терминал и вводим:
sudo pm-hibernate
Если компьютер успешно заснул и вышел из гибернации, то делаем
sudo mousepad /var/lib/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
в открывшимся окне вводим

[Re-enable hibernate by default in upower]

 Identity=unix-user:*

 Action=org.freedesktop.upower.hibernate

 ResultActive=yes

 [Re-enable hibernate by default in logind]

 Identity=unix-user:*

 Action=org.freedesktop.login1.hibernate

 ResultActive=yes



сохраняем, перезагружаемся.
Далее в настройках менеджера питания выставляем при закрытии крышки ноутбука - спящий режим. По крайней мере у меня так корректно все работает.

Да и самое главное объем swap раздела должен быть достаточным 1,5...2 объема оперативной памяти