- +

Автор: linaleks Тема: Direct Rendering No. Видеокарта Intel не запускается. Драйвера все установлены.  (Прочитано 1947 раз)

Оффлайн linaleks

  • Начинающий
  • *
  • Сообщений: 2
  • Репутация: +0/-0
    • Просмотр профиля
Приветствую форумчан! В Ubuntu новичок и вопрос может быть идиотским, но всё же я не смог решить его гуглением.

Задача: запустить 3d ускорение.
На данный момент имеем direct rendering: No
glxinfo -i | grep render
libGL error: no matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
direct rendering: No (-i specified)
    GLX_MESA_multithread makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Mesa GLX Indirect

Теперь нюансы:
 
- процессор Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz

- видеокарта интегрирована в процессор
lspci -ks `lspci|grep VGA|awk '{print $1}'`
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
        Subsystem: ASUSTeK Computer Inc. Device 844d
        Kernel driver in use: i915

- система
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:        14.10
Codename:       utopic

- это сервер, к которому я подключаюсь удалённо:
это арендованный на hetzner компьютер
графическая оболочка xfce поставлена поверх серверной ubuntu
подключение по xrdp



- видеодрайвер intel, ставил с официального сайта.



- логи Xorg
cat /var/log/Xorg.0.log | grep -i driver
[    17.150]    X.Org Video Driver: 18.0
[    17.150]    X.Org XInput driver : 21.0
[    17.324] (==) Matched intel as autoconfigured driver 0
[    17.324] (==) Matched intel as autoconfigured driver 1
[    17.324] (==) Matched modesetting as autoconfigured driver 2
[    17.324] (==) Matched fbdev as autoconfigured driver 3
[    17.324] (==) Matched vesa as autoconfigured driver 4
[    17.324] (==) Assigned the driver to the xf86ConfigLayout
[    17.325] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    17.353]    Module class: X.Org Video Driver
[    17.353]    ABI class: X.Org Video Driver, version 18.0
[    17.354] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    17.354]    Module class: X.Org Video Driver
[    17.354]    ABI class: X.Org Video Driver, version 18.0
[    17.354] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    17.354]    Module class: X.Org Video Driver
[    17.354]    ABI class: X.Org Video Driver, version 18.0
[    17.354] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    17.354]    Module class: X.Org Video Driver
[    17.354]    ABI class: X.Org Video Driver, version 18.0
[    17.354] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
[    17.354] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    17.354] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    17.354] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    17.354] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    17.354] (II) FBDEV: driver for framebuffer: fbdev
[    17.354] (II) VESA: driver for VESA chipsets: vesa
[    17.358] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20140905
[    17.360]    ABI class: X.Org Video Driver, version 18.0
[    17.367] (II) intel(0): [DRI2]   DRI driver: i965
[    17.367] (II) intel(0): [DRI2]   VDPAU driver: i965
[    17.517]    Module class: X.Org XInput Driver
[    17.517]    ABI class: X.Org XInput driver, version 21.0
[    17.517] (II) Using input driver 'evdev' for 'Power Button'
[    17.519] (II) Using input driver 'evdev' for 'Video Bus'
[    17.519] (II) Using input driver 'evdev' for 'Power Button'
[    17.519] (II) Using input driver 'evdev' for 'Eee PC WMI hotkeys'
[    17.520] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'



- порядок моих действий:
1) на сервере поставил xfce apt-get -y install xubuntu-desktop
2) поставил xrdp apt-get -y install xrdp
3) поправил конфиг /etc/xrdp/startwm.sh
[spoiler]
                    #!/bin/sh
   
                    if [ -r /etc/default/locale ]; then
                      . /etc/default/locale
                      export LANG LANGUAGE
                    fi
                    #. /etc/X11/Xsession
                    startxfce4
и service xrdp restart
4) долго мучался с установкой дров от Intel, т.к. установщик ругался на отсутствие чипсета i915. В итоге оказалось, что он в блеклистах на загрузку /etc/modprobe.d/blacklist-hetzner.conf Я соответственно закомментил блеклист, i915 запустился и дрова на интел встали нормально.
### Hetzner Online AG - installimage
### silence any onboard speaker
blacklist pcspkr
### i915 driver blacklisted due to various bugs
### especially in combination with nomodeset
# blacklist i915
# blacklist i915_bdw
# install i915 /bin/true
### mei driver blacklisted due to serious bugs
blacklist mei
blacklist mei_me


5) Хотя дрова встали вроде бы, но всё равно при запросе инфы о видеокарте не выдавалось сообщения, что используется модуль ядра какой-либо, методом научного тыка добавил в файл /etc/modprobe.d/modesetting.conf
options i915 modeset=1
[/spoiler]


После всего этого получается, что модуль i915 подцепляется, видеокарта поддерживается интелловским драйвером, но всё равно система не пользуется ей для 3д ускорения, а пытается заюзать непрямые методы. Что меня шокирует и опускаются руки.  :o Need Help!



Оффлайн butjapka

  • Global Moderator
  • Старожил
  • *****
  • Сообщений: 1232
  • Репутация: +119/-0
  • Xubuntu 16.04 LTS
    • Просмотр профиля
Можно состав железок  подробнее.
sudo apt install inxi
Затем
sudo inxi -v5
Вывод сюда

Оффлайн linaleks

  • Начинающий
  • *
  • Сообщений: 2
  • Репутация: +0/-0
    • Просмотр профиля
System:    Host: Ubuntu-1410-utopic-64-minimal Kernel: 3.16.0-34-generic x86_64 (64 bit gcc: 4.9.1)
           Console: tty 7 Distro: Ubuntu 14.10 utopic
Machine:   Mobo: ASUSTeK model: P8H67-M PRO v: Rev X.0x serial: MF70B8G03300127
           Bios: American Megatrends v: 3806 date: 08/20/2012
CPU:       Quad core Intel Core i7-2600 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27291
           Clock Speeds: 1: 1606 MHz 2: 1599 MHz 3: 1599 MHz 4: 1674 MHz
           5: 1692 MHz 6: 1618 MHz 7: 1706 MHz 8: 1898 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.org 1.16.0 drivers: intel (unloaded: fbdev,vesa)
           tty size: 80x24 Advanced Data: N/A for root out of X
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: eth0 state: up speed: 1000 Mbps duplex: full
           mac: 14:da:e9:b3:91:f0
Drives:    HDD Total Size: 6001.2GB (0.2% used)
           ID-1: /dev/sda model: ST33000651AS size: 3000.6GB temp: 53C
           ID-2: /dev/sdb model: ST3000DM001 size: 3000.6GB temp: 49C
           Optical: No optical drives detected.
Partition: ID-1: / size: 1008G used: 3.8G (1%) fs: ext4 dev: /dev/md2
           label: N/A uuid: abb29d86-f919-4cd7-8708-661bf10b4be0
           ID-2: /boot size: 488M used: 42M (9%) fs: ext3 dev: /dev/md1
           label: N/A uuid: 7bebbb68-ccca-4e4b-bf9c-fb6304d2e82c
           ID-3: /home size: 1.7T used: 68M (1%) fs: ext4 dev: /dev/md3
           label: N/A uuid: 686fb2bc-ec66-4388-bf8a-bf9a205d97cb
           ID-4: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/md0
           label: N/A uuid: 3befbcd5-548e-4624-a212-ae1e719d2cbf
RAID:      Device-1: /dev/md2 - active components: online: sdb3[1] sda3[0]
           Info: raid: 1 report: 2/2 blocks: 1073610560 chunk size: N/A
           Device-2: /dev/md1 - active components: online: sda2[0] sdb2[1]
           Info: raid: 1 report: 2/2 blocks: 523968 chunk size: N/A
           Device-3: /dev/md0 - active components: online: sda1[0] sdb1[1]
           Info: raid: 1 report: 2/2 blocks: 8384448 chunk size: N/A
           Device-4: /dev/md3 - active components: online: sda4[0] sdb4[1]
           Info: raid: 1 report: 2/2 blocks: 1847478528 chunk size: N/A
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 238 Uptime: 5:01 Memory: 438.9/15757.2MB
           Init: Upstart runlevel: 2 Gcc sys: 4.9.1
           Client: Shell (bash 4.3.301) inxi: 2.1.28