Сетевые карты от Realtek

Автор black-owl, сентября 09, 2015, 20:37:05

« предыдущая - следующая »

black-owl

сентября 09, 2015, 20:37:05 Последнее редактирование: сентября 10, 2015, 05:57:23 от butjapka
Свежеустановленная Xubuntu 14.04.03, ноутбук Lenovo G560.
Там сетевушка от realtek, печально известная среди пользователей Линукса. Для лечения призывают использовать старый драйвер: r8168 вместо r8169.
Я скомпилировал его, добавил в автозагрузку, заблэклистил r8169, перезагрузился и .... Сети нет.
Модуль r8168 загружен, r8169 - нет, lspci показывает, что сетевушка определена, но нет строки Kernel driver in use.
Каким образом я должен указать сетевой карте, что ей следует работать с модулем r8168?

butjapka

sudo apt install inxi
sudo inxi -N

вывод сюда

black-owl

Вывод:

Network:   Card-1: Intel Centrino Advanced-N + WiMAX 6250 [Kilmer Peak] driver: iwlwifi
                Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller

Прошу прощения за резкие высказывания.

butjapka

у меня сетевуха один в один,
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: bcma-pci-bridge

модуль подключен, попробуйте вернуть модуль из блэклиста.
Запустите в лайв сесии, посмотрите там будет работать?
Дальше будем думать.

black-owl

Я возвращал r8169 обратно, чтобы написать сообщение сюда, но он работает крайне нестабильно. Сеть падает при высокой нагрузке или просто через часа пол работы. Дабы заставить её работать снова - приходится rmmod и modprobe его снова.
В лайв-сессии загружен r8169 и работает так же, как сейчас.

butjapka

Была у меня подобная проблема, но связана не с установленным железом, а с кабелем провайдера, пока не побазарил с ними, проблему не решали. Если есть возможность попробуйте подключиться к интернету у друзей, проверить работу карточки на другой линии.

black-owl

Вин7 в дуалбуте проблем не испытывает. Пробовал подключаться у родителей к их кабелю - то же самое было. Во время моего первого знакомства с линуксами - года 2-3 назад - я, помнится, решил эту проблему этим же способом.

butjapka

сентября 10, 2015, 22:04:21 #7 Последнее редактирование: сентября 11, 2015, 05:57:47 от butjapka
попробуйте скачать этот архив
распаковать, затем скомпилить его

cd r8101-1.027.00/src/     
make clean modules   
sudo make install   
sudo depmod -a
sudo modprobe r8101

black-owl

Не компилируется.

root@vlad-Lenovo-G560:/home/vlad/Рабочий стол/r8101/r8101-1.027.00# make clean modules
make -C src/ clean
make[1]: Entering directory `/home/vlad/Рабочий стол/r8101/r8101-1.027.00/src'
make -C /lib/modules/3.19.0-28-generic/build SUBDIRS=/home/vlad/Рабочий стол/r8101/r8101-1.027.00/src clean
make[2]: Entering directory `/usr/src/linux-headers-3.19.0-28-generic'
arch/x86/Makefile:129: CONFIG_X86_X32 enabled but no binutils support
Makefile:669: Cannot use CONFIG_CC_STACKPROTECTOR_REGULAR: -fstack-protector not supported by compiler
make[2]: *** No rule to make target `стол/r8101/r8101-1.027.00/src'.  Stop.
make[2]: Leaving directory `/usr/src/linux-headers-3.19.0-28-generic'
make[1]: *** [clean] Error 2
make[1]: Leaving directory `/home/vlad/Рабочий стол/r8101/r8101-1.027.00/src'
make: *** [clean] Error 2


Гугл по поводу этого посоветовал обновить gcc, что я и сделал, выполнив

add-apt-repository ppa:ubuntu-toolchain-r/test
apt-get update
apt-get upgrade gcc


Но это не помогло, получаю ту же самую ошибку.

black-owl

Перечитал сообщение об ошибке и заметил, что в строке присутствуют кириллические символы. Перенёс папку с сырцами в /home, там всё собралось. Модуль заработал, соединение есть. Потестирую под нагрузками и аптайм (если вылетит), отпишусь.
Пока всё в порядке, большое спасибо, выручили меня. Под виндой невозможно работать было, оперативки жрёт крайне много, а её всего 2 гига. Еще и RoR не работают без костылей, а тут всё отлично встало. :glass: