- +

Автор: Гость Тема: Сетевые соединения  (Прочитано 5773 раз)

bsp134

  • Гость
Сетевые соединения
« : Май 25, 2012, 21:24:45 »
Работаю с XUbuntu 12.04 , всё работает и устраивает.
Сеть настроена при помощи xnetcardconfig - режим автоопределения настроек .
Кроме того установлен gnome-network-admin , network-manager-gnome .

После очередных dist-upgrade настройки слетают.
Обычно это отсутствие в авто запуске NetworkManager  и требуется реконфигурация сетевого соединения в xnetcardconfig .
В /etc/network/interfaces после dist-upgrade иногда перескакивает на статические настройки IP , netmask.
Решаю редактированием  в авто определение :
auto eth0
iface eth0 inet dhcp
и :
sudo /etc/init.d/networking restart
Если пропадает NetworkManager в панели задач , то перезапускаю его :
sudo service network-manager stop
sudo rm /var/lib/NetworkManager/NetworkManager.state
sudo service network-manager start
Может быть есть утилита управления сетевыми соединениями (картами) не требующая таких действий после апгрейдов ?
p.s. В принципе вопрос более сложен.
У меня две сетевые карты , два провайдера ADSL и LAN .
Управление автоматическим подключением в предыдущих убунтах было максимально просто в network-manager-gnome .
В 12.04 автоматически определилось только ADSL соединение , а сетевая карта для LAN  изначально без реконфигурации в   xnetcardconfig в nm  показывала , как "Проводная сеть . Устройство не готово"
« Последнее редактирование: Май 26, 2012, 12:43:47 от bsp134 »

Отмечено, как лучший ответ пользователем Февраль 17, 2014, 18:53:05

Оффлайн xf∞

  • xfce 4.11
  • Старожил
  • *****
  • Сообщений: 808
  • Репутация: +50/-0
  • Xubuntu 12.04.4
    • Просмотр профиля
Сетевые соединения
« Ответ #1 : Май 26, 2012, 14:50:48 »
т.е. вы хотите, чтобы после обновления, к примеру, с 11,10 на 12,04 всё оставалось нормальным?
такое обновление не рекомендуется делать. хотя у кого-то это получается без проблем.
Делаю нескучные обои и рисую темы для xfce.

Оффлайн denkin

  • Global Moderator
  • Старожил
  • *****
  • Сообщений: 1579
  • Репутация: +74/-2
    • Просмотр профиля
Сетевые соединения
« Ответ #2 : Май 26, 2012, 15:42:02 »
однажды удалось обновится последовательно и относительно успешно с ubuntu 10.04 до 10.10, а затем до 11.04, на одной машине, но как то все медленней работало, пока не установил 11.04 c нуля. В общем то прочитав на forum.ubuntu.ru любую тему об обновлении/установке нового релиза, можно сделать вывод - лучше ставить с нуля!

ЗЫ. А есть опыт успешного обновления у кого нибудь с win XP до win Vista??? Просто интересно.

bsp134

  • Гость
Сетевые соединения
« Ответ #3 : Май 26, 2012, 19:49:52 »
т.е. вы хотите, чтобы после обновления, к примеру, с 11,10 на 12,04 всё оставалось нормальным?
такое обновление не рекомендуется делать. хотя у кого-то это получается без проблем.
Видимо неправильно былa растолкованa вчерашняя редакция первого поста  по поводу предыдущего использования убунт версий с 9-ой по последнюю.  A если бы я ещё написал про предыдущий опыт использования в быту OpenSuse, Mandriva, Open Embedded Linux.... :-\
Уcтановку Xubuntu 12.04  естественно я использовал "вчистую" с низкоуровневым форматированием под неё раздела ext4 диска с предыдущей Ubuntu 11.10 .
В убунтах после установки оси для настройки сетевых соединений используется nm . Я подключён к двум провайдерам - по adsl и LAN.
Так вот в убунтах nm корректно определял сетевые соединения и в нём просто было настроить какое из них использовать при загрузке системы , а какое включать вручную при необходимости . Есстественно отключив вручную в nm-appletе предыдущее соединение.
А сейчас что-то не получается так настроить соединения . Даже если я снимаю флаг с eth1 в nm , все равно оно при загрузке системы подключается одновременно с eth0
Вопрос как разделить эти два соединения на автоматическое и вручную.
На данный момент использую по умолчанию eth1 (adsl доступ) . В /etc/network/interfaces :
auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp
интересно куда нужно вводить пароль , чтобы сохранить текущие настройки при условии , что nm-applet  из консоли не стартует

закончилось тем , что снёс xnetcardconfig, nm-applet вместе с Network manager. Поставил wicd и в нём произвёл настройки для дефолтного соединения и добавив адсл коннект получил возможность "переключения налету". Значок wicd вывел в панель задач для визуального контроля и быстрого доступа к инфо по соединениям.
« Последнее редактирование: Май 28, 2012, 21:30:52 от bsp134 »