Compiz и шапки окон

Автор Bird, мая 30, 2012, 13:16:15

« предыдущая - следующая »

Bird

Только что установил Xubuntu 12.04 и установил Compiz. После включения эффектов компиза исчезли шапки окон. Это у всех такая проблема?
Знаю что такое было(не каждый раз) в Ubuntu 10.04, там можно было хотя бы выполнить compiz --replace и это помогало. Здесь же не помогает и это.

denkin

а чем xfwm4 не угодил? по теме, посмотрите в диспетчере настроек xfce в разделе сеансы и запуск - может там висит запуск xfwm4 и они с компизом не поделились?

Bird

я удалил compiz, а шапки окон так и не вернулись. любое открываемое окно открываеться в левом верхнем углу.
ди и еще пробывал ставить Cairo-Dock, он не запустился и я его удалил. Теперь еще и шрифты изменились. Как всё вернуть обратно?

butjapka

мая 30, 2012, 15:02:17 #3 Последнее редактирование: мая 30, 2012, 15:16:47 от butjapka
XFCE 4.10 > посмотрите в настройках панели не стоит ли чекбокс "Не резервировать место у краев"

Если есть, уберите. При включенном режиме шапки окон прячутся под панель.
И как вариант можно попробовать
xfwm4 --replace

Bird

Вообщем это неисправимый глюк компиза как в gnome2 так и xfce. Решено- ухожу на linuxmint.

nikolaich

Цитата: Bird от мая 30, 2012, 15:24:26
Решено- ухожу на linuxmint.

Linux Mint не лучший вариант.Сам пробовал-МАТЕ и Cinnamon "сырые".

TAST

мая 31, 2012, 20:40:30 #6 Последнее редактирование: мая 31, 2012, 20:43:50 от TAST
Приветствую всех пользователей!!!

Сопственно проблема та же. Правда из положения можно выйти, если сделать верхнюю панель в автоскрытие или из той же панели в трее, путём нажатия правой кнопки мыши, выбрать - "переместить". Но это не совсем удобно. Перезапуск xfwm4 отключает compiz и включает обычные эфекты, что тоже "не есть гут".

С Xubuntu не знаком, так как до этого пользовал Kubuntu8.04, Ubuntu10.04, после выхода Unity, ушёл на Debian 6 (GNOME). Паралельно стоит винда, только для игрушек (очень ралли люблю). Просто с Wine возица нет времени.

Карта: MSi Radeon HD 5450 Cedar Pro, 1024 mb

Всё дело в том, что я установил  все пакеты compiz, может быть в этом проблема? Может только пакеты Gtk compiz надо устанавливать?

TAST

Будут какие идеи..

Вот ещё неприятность, при работе компиза, переключение рабочих столов - пропадают все панели и помогает только принудительная переззагрузка.

butjapka

Цитата: TAST от мая 31, 2012, 23:11:19
Будут какие идеи..

Вот ещё неприятность, при работе компиза, переключение рабочих столов - пропадают все панели и помогает только принудительная переззагрузка.

Enabling Compiz On Xubuntu

хазар

все просто!  sudo apt-get install compiz compizconfig-settings-manager gconf-editor
затем заходим в ccsm и ставим галки на opengl и нна другие необходимые вам элементы по расширению функций рабочего стола,пертаскивание и изменение раззмеров окон...
затем заходим в gconf-editor идем в /apps/gwd/use_metacity_theme - ставим галку, /apps/metacity/general в параметре theme нужно вписать название используемой темы в которой есть metaciti
затем добавляем в автозагрузку compiz --replace и перезагружаемся

butjapka

Цитата: хазар от июня 01, 2012, 13:36:56
затем заходим в gconf-editor

Здесь вам не тут, это XFCE. Нет в системе gconf-editor

хазар

Цитата: butjapka от июня 01, 2012, 14:10:44
Цитата: хазар от июня 01, 2012, 13:36:56
затем заходим в gconf-editor

Здесь вам не тут, это XFCE. Нет в системе gconf-editor


откройте synaptic вбейте в поиск gconf и посмотрите ,а точнее убедитесь что он установлен)
а gconf-editor это всеголиш пакет для конфигурации в графическом виде.если религия не поволяет его установить то сконфигурировать можно и по средствам текстового редактора, отобразив в thunar скрытые файлы и заглянув в папку .gconf
compiz использует metacity для которого в gconf по умолчанию прописана тема adwata

xf∞

ЦитироватьЗдесь вам не тут, это XFCE. Нет в системе gconf-editor
может быть, с компизом поставился. если всё-таки нет или не хочется его открывать, то настройку темы можно сделать в ubuntu-tweak.
Делаю нескучные обои и рисую темы для xfce.

TAST

июня 02, 2012, 11:39:38 #13 Последнее редактирование: июня 02, 2012, 11:41:25 от TAST
Цитата: хазар от июня 01, 2012, 13:36:56
1)  gconf-editor идем в /apps/gwd/use_metacity_theme - ставим галку--- Я не смог найти этот вариант, /apps/metacity/general - этот нашол.