- +

Автор: bezja Тема: проблемы при проигрывании видео/аудио  (Прочитано 8250 раз)

Оффлайн bezja

  • Постоялец
  • **
  • Сообщений: 81
  • Репутация: +2/-0
  • Voyager-13.04-desktop-x64
    • Просмотр профиля
Здравствуйте, форумчане. Скажите пожалуйста:никто никогда не сталкивался с проблемами проигрывания видео/аудио? Суть проблемы: при запуске аудио файлов время от времени при воспроизведении композиция на доли секунды начинает заикаться. Причем это не проблема в аудио формате. Если перемотать на место заикания то его уже не будет..Беда, как я думаю, к кодеках..Какие только программы я не пробовал - audacious, deadbeef, totem все равно этот глюк проявляется. Такая же фигня и при просмотре видео -  на разных моментах происходит то заикание голоса, некоторые плееры вообще вырубаются, VLC заикаится, SMPlayer тоже как-то поддергивается. В общем время от времени видео/аудио идет прерывисто. Если обратно на участок глюка перемотать, то его нет. Те же самые файлы смотрел под виндой - ничего такого не наблюдается. Да даже на работе на убунте 10.04 такого нет...В чем может быть проблема в таком случае? ubuntu-restricted-extras установлены..Или может в параметрах проигрывателя надо где-нибудь подкрутить что-то..

Оффлайн bezja

  • Постоялец
  • **
  • Сообщений: 81
  • Репутация: +2/-0
  • Voyager-13.04-desktop-x64
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #1 : Сентябрь 16, 2012, 21:34:29 »
хочу добавить, что такая ерунда проявляется только с файлами, которые расположены на винте. Если слушать онлайн радио через тот же самый audacious то ничего подобного не проявляется

Оффлайн bezja

  • Постоялец
  • **
  • Сообщений: 81
  • Репутация: +2/-0
  • Voyager-13.04-desktop-x64
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #2 : Сентябрь 16, 2012, 22:00:08 »
нашел единственное решение  -
/etc/modprobe.d/alsa-base.conf
В конец файла дописать - options snd-hda-intel model=generic. Сохранить, перезагрузиться. Поменял в настройках audacious плагин вывода  - ALSA (до этого был Pulseeaudio). Но все равно - то пару песен без проблем, то в начале третьей заикание начинается на доли секунды...Не знаю куда еще копать..

Оффлайн bezja

  • Постоялец
  • **
  • Сообщений: 81
  • Репутация: +2/-0
  • Voyager-13.04-desktop-x64
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #3 : Сентябрь 17, 2012, 18:27:25 »
По-моему, нашел в чем причина: все файлы (аудио/видео) хранятся у меня на втором жестком диске (ntfs). Сейчас перетащил пару фильмов на раздел под линуксом в настройках smplayer выставил вывод через vdpau и все работает без тормозов. Тему пока закрывать не буду. Поэкспериментирую с аудио файлами. Если догадка подтвердится, то вердикт будет вынесен и записан на форуме:)

Оффлайн xf∞

  • xfce 4.11
  • Старожил
  • *****
  • Сообщений: 808
  • Репутация: +50/-0
  • Xubuntu 12.04.4
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #4 : Сентябрь 17, 2012, 19:58:02 »
да. с дисками ntfs такое вполне возможно.
потому что скорость чтения/записи на этой ФС ниже, чем на винде(ну, вообще это её система).

и фильмы, случайно, не hd-качества? у меня на слабом пк тоже тормозили, на xfce - меньше.
Делаю нескучные обои и рисую темы для xfce.

Оффлайн bezja

  • Постоялец
  • **
  • Сообщений: 81
  • Репутация: +2/-0
  • Voyager-13.04-desktop-x64
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #5 : Сентябрь 17, 2012, 20:02:23 »
Нет, дело не в компе. Он у меня достаточно мощный. Насчет фильмов сейчас сказать не могу. Смотрю разного качества. И там и там бывали глюки. Пока проверить свою догадку не смог. Нет времени на фильм:). Как сделаю - сразу отпишусь

Оффлайн denkin

  • Global Moderator
  • Старожил
  • *****
  • Сообщений: 1537
  • Репутация: +73/-2
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #6 : Сентябрь 17, 2012, 20:34:32 »
"Кривая" работа с ntfs-разделами вполне возможна.

Оффлайн Труба Шатал

  • Жилец
  • ****
  • Сообщений: 418
  • Репутация: +21/-1
  • xubuntu14.04
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #7 : Сентябрь 18, 2012, 06:58:37 »
ntfs-3g, кстати, недавно обновлялся.
может из-за этого проблемы.

Оффлайн bezja

  • Постоялец
  • **
  • Сообщений: 81
  • Репутация: +2/-0
  • Voyager-13.04-desktop-x64
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #8 : Сентябрь 19, 2012, 10:34:41 »
Люди:), подскажите что делать...Все равно проявляются эти глюки в видео. через мин 10-15 происходит кратковременное заикание звука/видео...Не знаю на что и подумать..На работе стоит комп с 10.04 тут любой формат без проблем воспроизводится, хотя комп намного слабее домашнего.. Дома же некоторые mp4 файлы вообще при проигрывании на одном месте встают и все...Не знаю на что и думать..То ли в видюхе дело (на работе ATI RADEON, дома - NVIDIA). То ли кодеки кривые. Думал что дело в разделе ntfs на котором были файлы. Перекинул все на раздел под Линуксом, но история та же..Если у кого NVIDIA подскажите плеер которым вы пользуетесь и какие в нем настройки выставлены..Надоело это дерганье видеть уже..

Оффлайн butjapka

  • Global Moderator
  • Старожил
  • *****
  • Сообщений: 1224
  • Репутация: +118/-0
  • Xubuntu 16.04 LTS
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #9 : Сентябрь 19, 2012, 10:52:35 »
посмотрите
htop, какой процесс грузит?

Оффлайн bezja

  • Постоялец
  • **
  • Сообщений: 81
  • Репутация: +2/-0
  • Voyager-13.04-desktop-x64
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #10 : Сентябрь 19, 2012, 11:00:48 »
Хорошо. Я посмотрю. Вот только заикание-то идет буквально на секунду..Какой процесс подвисает именно в этот момент не думаю, что успею разглядеть:). Посмотрю какие процессы тогда вообще грузятся у меня при просмотре видео. Ну или найду сегодня этот файл mp4 которые при переводе в полноэкранный режим у меня вообще встал на одном месте.. Потом отпишусь

Оффлайн Труба Шатал

  • Жилец
  • ****
  • Сообщений: 418
  • Репутация: +21/-1
  • xubuntu14.04
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #11 : Сентябрь 20, 2012, 09:22:09 »
похоже на это самое:
https://forum.xubuntu-ru.net/index.php?topic=200.0


Оффлайн butjapka

  • Global Moderator
  • Старожил
  • *****
  • Сообщений: 1224
  • Репутация: +118/-0
  • Xubuntu 16.04 LTS
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #12 : Сентябрь 20, 2012, 16:45:09 »
Попробуйте этот вариант

Оффлайн xf∞

  • xfce 4.11
  • Старожил
  • *****
  • Сообщений: 808
  • Репутация: +50/-0
  • Xubuntu 12.04.4
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #13 : Сентябрь 20, 2012, 18:14:18 »
я пользуюсь vlc.
как вариант, можете загрузиться с живой флешки и без дров попробовать в плеерах воспроизвести.
Делаю нескучные обои и рисую темы для xfce.

Оффлайн bezja

  • Постоялец
  • **
  • Сообщений: 81
  • Репутация: +2/-0
  • Voyager-13.04-desktop-x64
    • Просмотр профиля
проблемы при проигрывании видео/аудио
« Ответ #14 : Сентябрь 20, 2012, 21:06:50 »
Попробуйте этот вариант
Хорошо, спасибо. Сейчас проверю:)