- +

Автор: scofield Тема: x11vnc + xdmcp  (Прочитано 4954 раз)

Оффлайн scofield

  • Начинающий
  • *
  • Сообщений: 6
  • Репутация: +0/-0
    • Просмотр профиля
x11vnc + xdmcp
« : Март 31, 2014, 09:46:25 »
Добрый день.

Установил x11vnc . Хотелось бы настроить xdmcp, т.е.  перенастроить локальный XDMCP-сервер так, чтобы он помогал X-серверу, встроенному в VNC, обеспечить недостающую многопользовательскую аутентификацию.

И на выходе получить : пользователь подключается к серверу видит окно авторизации. так что с компьютером могут работать сколько угодно пользователей.

xubuntu 13.10

Cогласно данной статье
http://www.ibm.com/developerworks/ru/library/os-multiuserloginsvnc/

xinid.conf


service vnc
service vnc
{
   disable     = no
   socket_type = stream
   protocol    = tcp
   wait        = no
   user        = nobody
   server      = /usr/bin/x11vnc
   server_args = -safer -nopw  -once -viewonly -display :0
   type        = UNLISTED
   port        = 5900
}


Cтартую сервис xinetd


root@scofield-HP:~# /etc/init.d/xinetd start
 * Starting internet superserver xinetd                                  [ OK ]
root@scofield-HP:~#


При этом на клиентской машине "Unsuppoted protocol"
« Последнее редактирование: Март 31, 2014, 10:23:38 от scofield »

Оффлайн scofield

  • Начинающий
  • *
  • Сообщений: 6
  • Репутация: +0/-0
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #1 : Март 31, 2014, 10:49:59 »
Сделал xinetd.conf таким

service x11vnc
{
   disable     = no
   socket_type = stream
   protocol    = tcp
   wait        = no
   user        = root
   server      = /usr/bin/x11vnc
   server_args = -inetd -o /var/log/x11vnc.log -display :0
   type        = UNLISTED
   port        = 5900
}


Подключается , но на экране сессия текущего пользователя . а не окно авторизации.
И что  думаю , что дело в этой строчке :
-auth-display :0
« Последнее редактирование: Март 31, 2014, 10:56:56 от scofield »

Оффлайн destruct™

  • Завсегдатай
  • ***
  • Сообщений: 222
  • Репутация: +25/-0
  • Xubuntu 14.04 x64
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #2 : Март 31, 2014, 12:05:27 »
не берусь утверждать, но из конфига видно что указан конкретный юзер, вернее root. я бы создал группу пользователей remote, налепил бы пользователей, и для них разрешил бы в конфиге (вместо user = root вписал бы group = remote) думаю это было бы правильнее)


UPD. всё вышесказанное лирика) читаем Настройка XDMCP-сервера на этой страничке и думаю многое проясняется)
« Последнее редактирование: Март 31, 2014, 12:19:09 от destruct™ »

Оффлайн scofield

  • Начинающий
  • *
  • Сообщений: 6
  • Репутация: +0/-0
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #3 : Март 31, 2014, 12:39:24 »
в настройки lightdm.conf добавленно только :


[Xdmcp]
enable=true


Клиентский ПК лучает рабочий стол текущего пользователя.
Необходимо получить форму авторизации.

Для  того чтоб это сделать нужно править конфиг lightdm или xinetd ?

Оффлайн destruct™

  • Завсегдатай
  • ***
  • Сообщений: 222
  • Репутация: +25/-0
  • Xubuntu 14.04 x64
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #4 : Март 31, 2014, 13:42:00 »
Внимательнее читаем)
Цитировать
-query localhost. Этот параметр указывает, что сервер VNC X должен проверять систему localhost на аутентификацию XDMCP.
Конфиг выходит примерно такой:
Код: xinetd.conf [Выделить]
service  x11vnc
{
   disable     = no
   socket_type = stream
   protocol    = tcp
   wait        = no
   user        = nobody
   server      =  /usr/bin/x11vnc
   server_args = -inetd -o /var/log/x11vnc.log -once -query localhost -securitytypes=none
   type        = UNLISTED
   port        = 5900
}

можно ещё ограничить кол-во сессий
Код: lightdm.conf [Выделить]
[xdmcp]
Enable=true
MaxSessions=10

Выполняем
 /etc/init.d/lightdm restart
И проверяем)

Оффлайн scofield

  • Начинающий
  • *
  • Сообщений: 6
  • Репутация: +0/-0
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #5 : Март 31, 2014, 14:00:43 »
ПРи попытке подключения имеем :


>>> sending remote command: "qry=localhost" via X11VNC_REMOTE X property.
error: could not connect to an x11vnc server at :0.0  (rc=1)


Оффлайн destruct™

  • Завсегдатай
  • ***
  • Сообщений: 222
  • Репутация: +25/-0
  • Xubuntu 14.04 x64
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #6 : Март 31, 2014, 15:42:13 »
а в логе /var/log/x11vnc.log что пишется?

а если добавить -display :0
server_args = -inetd -o /var/log/x11vnc.log -display :0 -once -query localhost -securitytypes=none
« Последнее редактирование: Март 31, 2014, 15:50:09 от destruct™ »

Оффлайн scofield

  • Начинающий
  • *
  • Сообщений: 6
  • Репутация: +0/-0
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #7 : Март 31, 2014, 15:48:45 »
Вот это и пишется , в обоих случаях :


>>> sending remote command: "qry=localhost" via X11VNC_REMOTE X property.
error: could not connect to an x11vnc server at :0  (rc=1)

Оффлайн destruct™

  • Завсегдатай
  • ***
  • Сообщений: 222
  • Репутация: +25/-0
  • Xubuntu 14.04 x64
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #8 : Март 31, 2014, 17:30:34 »
у меня железяка никак тесты на себе не выдержит, потому остаётся только ждать наших гуру, чтоб посоветили куда более наглядно, чем единственно верный вариант - курить мануал. смотрим lightdm и xinetd man. или гуглим чонить типа этого.
« Последнее редактирование: Март 31, 2014, 17:32:51 от destruct™ »

Оффлайн scofield

  • Начинающий
  • *
  • Сообщений: 6
  • Репутация: +0/-0
    • Просмотр профиля
Re: x11vnc + xdmcp
« Ответ #9 : Апрель 01, 2014, 11:26:12 »
lightdm.conf

[SeatDefaults]
autologin-guest=false
autologin-user-timeout=0
autologin-session=lightdm-autologin
greeter-session=lightdm-gtk-greeter
user-session=xubuntu
xserver-allow-tcp=true

[XDMCPServer]
enabled=true


gedit /etc/xinetd.d/vnc


service  x11vnc
{
   disable     = no
   socket_type = stream
   protocol    = tcp
   wait        = no
   user        = scofield
   server      =  /usr/bin/x11vnc
   server_args = -once             
   type        = UNLISTED
   port        = 5900
}




и по данной статье http://white55.ru/xubuntu.html