Помогите переписать скрипт установки принтера

Автор Kamrad, июня 15, 2014, 11:39:05

« предыдущая - следующая »

Kamrad

Доброго времени суток, друзья!
Некоторое время назад попался мне очень удачный скрипт (см. вложения), который беспроблемно прицеплял принтеры Canon на любые "бунты". Но вот оказия - данный скрипт был "завязан" на ресурс UbuntuOne, который теперь закрыт. Вопрос к программистам - как грамотно модифицировать скрипт, чтобы он обращался не к сетевому ресурсу, а к локальным файлам в домашнем каталоге?
Кто хочет на компьютере юзить, музить и вузить - пусть купит себе вульвузеллу!

"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!"

werwolf

июня 15, 2014, 12:07:12 #1 Последнее редактирование: июня 15, 2014, 14:27:28 от VJM

Kamrad

Кто хочет на компьютере юзить, музить и вузить - пусть купит себе вульвузеллу!

"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!"

Kamrad

Чтобы не плодить тем-клонов - указанный скрипт не устанавливает принтеры серии Canon LBP на дистрибтивах, начиная с 16.04 и новее -

"dpkg-deb: ошибка: «cndrvcups-common_3.21-1_amd64.deb» не является архивом в формате debian
dpkg: ошибка при обработке архива cndrvcups-common_3.21-1_amd64.deb (--install):
подпроцесс dpkg-deb --control возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
cndrvcups-common_3.21-1_amd64.deb
Ошибка при установке пакета cndrvcups-common_3.21-1_amd64.deb"
Кто хочет на компьютере юзить, музить и вузить - пусть купит себе вульвузеллу!

"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!"