Неправильное разрешение монитора. Intel HD4000

Автор miroshnik, октября 12, 2014, 16:28:42

« предыдущая - следующая »

miroshnik

Здравствуйте. Имеется ноутбук, процессор core i3, соответственно видеоадаптер встроенный HD4000.
Родное разрешение ноута 1366х768, с этим все нормально. Но при подключении Full HD монитора по VGA, я не могу выставить на мониторе разрешение выше 1024х768.
На винде и на другом дебиан дистрибутиве работало все нормально.

ОС: Xubuntu 14.04
Версия ядра: 3.13.0-37-generic

Пробовал вручную создавать xorg.conf

[spoiler]Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   # 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
  Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      " Configured Monitor"
   Device      "Configured Video Device"
EndSection
[/spoiler]

Повторюсь, что xorg.conf  я создавал вручную, так что может быть что-то неправильно.

Игорь

октября 12, 2014, 22:10:02 #1 Последнее редактирование: октября 12, 2014, 22:14:38 от Игорь
Стоящего посоветовать не могу, но выложу содержимое своего файла в Debian.
[spoiler]# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 340.32  (buildd@barber)  Wed Aug 20 07:46:44 UTC 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
[/spoiler]

miroshnik

Проблема решилась путем смены vga-кабеля... Причем это очень странно, т.к. еще полтора месяца назад, я нормально подключал монитор по этому кабелю и на ноуте стоял дебиан дистрибутив... да и на винде сейчас все было хорошо...

denkin

Цитата: miroshnik от октября 16, 2014, 02:16:51
Проблема решилась путем смены vga-кабеля... Причем это очень странно, т.к. еще полтора месяца назад, я нормально подключал монитор по этому кабелю и на ноуте стоял дебиан дистрибутив... да и на винде сейчас все было хорошо...
видимо такое качество кабеля (буду иметь ввиду, т.к. планирую покупку дополнительного монитора для ноута домой)